Click here to load reader

QoS e Asterisk

  • View
    7.482

  • Download
    17

Embed Size (px)

DESCRIPTION

Conhecendo sua rede e montando uma estratégia de migração para VoIP

Text of QoS e Asterisk

  • 1. Rodrigo Ricardo Passos QoS e Asterisk Conhecendo sua rede e montando uma estratgia de migrao para VoIP

2. Apresentao

  • Rodrigo Ricardo Passos
  • [email_address]
  • Cursou Cincias da Computao na Universidade Catlica de Petrpolis. Atualmente tem desempenhado o papel de gestor da Plataforma e Servios de Comunicaes dos clientes do InfoLink, que visa integrar redes de dados e telefonia bem como todo o relacionamento com fornecedores e modelagem do projeto desde o pr-venda at o ps-venda. Coordenador doproduto de Telefonia IP TotalVox iPBX e responsvel pela rea de infra-estrutura do provedor InfoLink. especialista em Redes e possui amplo conhecimento em engenharia de trfego e Gesto de Segurana da Informao. Atuou em grandes projetos de startup no Rio de Janeiro e em projetos de telecomunicaes.Possui profundo conhecimento em equipamentos Cisco, e Sistemas Operacionais Linux, FreeBSD e OpenBSD.

3. Objetivos

  • Prover conhecimento e recursos tcnicos para os profissionais de redes que esto envolvidos com Telefonia IP
  • Debater e modelar os cenrios encontrados em diversos projetos prospectados pelas empresas na rea de servios de Telefonia IP
  • Disseminar conhecimento da diversidade de ambientes discutidos durante o tutorial

4. Agenda

  • Abordagem tecnolgica
  • Elaborao do pr-venda
  • Abordagem tcnica do ambiente encontrado
  • Definio do ambiente de inspeo
  • Elaborao do Projeto
  • Implementao do Projeto
  • Acompanhamento e ps-venda

5. Abordagem tecnolgica

  • O que QoS?
  • Pelo administrador
    • Conjunto de mecanismos utilizados em redes para garantir que aplicaes crticas tenham banda garantida
    • Jitter, Delay e perda de pacotes
  • Pelo usurio
    • Os usurios percebem que suas aplicaes esto funcionando perfeitamente
    • Voz, Vdeo e dados

6. Abordagem tecnolgica

  • Arquiteturas da QoS
    • IntServ (Integrated Services)
      • Caracteriza os servios por diferentes graus de comprometimento de recursos (banda passante e buffer)
      • Principais componentes
        • Controle de Admisso : Determina se um novo fluxo pode ser aceito sem interferir na QoS de fluxos admitidos anteriormente.
        • Escalonador de pacotes : Gerencia os buffers das filas de sada dos roteadores e estaes.
        • Classificador : Reconhece os fluxos segundo suas identificaes, mapeia os pacotes desses fluxos nas diferentes categorias de servios, notifica a funo de policiamento, os coloca nos buffers das filas de sada apropriadas.
        • Policiamento : Notifica se os pacotes notificados pelo classificador esto em conformidade com os parmetros de trfego e QoS negociados pelo fluxos, sendo que esses parmetros so informados durante o controle de admisso.

7. Abordagem tecnolgica

  • Arquiteturas da QoS
    • IntServ O protocolo RSVP (Resource reServation Protocol)
      • Protocolo utilizado para sinalizao na arquitetura IntServ
      • O transmissor anuncia as caractersticas do trfego
      • Os roteadores no caminho se organizam para reservar o recurso caracterizado pelo fluxo
      • Os roteadores mantm informaes dos estados de reserva
    • Consideraes
      • Pouco escalabilidade em redes de backbone, uma que manter os estado de reserva gera sobrecarga de processamento.
      • Em um enlace de Backbone OC-48 tpico de backbone, pode conter 37.500 fluxos de 64 Kbps).

8. Abordagem tecnolgica

  • Arquiteturas da QoS
    • IntServ Relacionamento entre componentes

Aplicao Classificadorde Pacotes Processo RSVP Escalonador De Pacotes Controle de Admisso Policiamento Classificadorde Pacotes Processo de Roteamento Processo RSVP Policiamento Controle de Admisso Escalonador De Pacotes Dados Dados RSVP RSVP 9. Abordagem tecnolgica

  • Arquiteturas da QoS - DiffServ
  • Modelo desenvolvido sobre a classificao de servios de forma diferenciada atravs de agregao de fluxo individuais
  • Resolve o problema da escalabilidade da arquitetura IntServ.
  • A agregao de fluxos realizada atravs da identificao da classe de servio em um ou mais campos especficos do cabealho dos pacotes IP.

10. Abordagem tecnolgica

  • Arquiteturas da QoS - DiffServ
  • Tipos de Classificao
      • MF(Multi-Field) Similar ao IntServ
      • BA(Behaviour Aggregated)
        • TOS (Type of Service) - DS - IPv 4
        • Traffic Class IPv 6
    • A marcao do DS acontece no Edge Router (ER)
    • As aplicaes podem efetuar a marcao na origem do pacote (NBAR)

11. Abordagem tecnolgica Arquiteturas da QoS DiffServ Domnio DiffServ TRs Transt Routers ERs Edge routers 12. Abordagem tecnolgica

  • EF (Expedited Forwarding) Encaminhamento Expresso
    • O PHB EF define garantias mais rgidas de QoS para aplicaes que so mais sensveis a variaes de tempo na rede
  • AF (Assured Forwarding) Encaminhamento assegurado
    • PHB AF utilizado por servios que no necessitam de garantias rgidas, para obter preferncia no trfego de seus pacotes na rede.

Arquiteturas da QoS -DiffServPHB - Per-Hop Behavior(Comportamento do encaminhamento) 13. Abordagem tecnolgica Arquiteturas da QoS -DiffServClassificao DiffServ no ER (Edge Router) 14. Abordagem tecnolgica Arquiteturas da QoS-DiffServClassificao DiffServ no ER (Edge Router) Compress header Fragment (link fragmentation and interleaving, Layer 2) Queue-limit Random-detect Bandwidth Fair-queue Priority Shape Mark (set QoS values) Police Drop Count Estimate bandwidth Match one or more attributes (partial list): Access Control List (ACL) CoS Differentiated Services Code Point (DSCP) Input-interface Media Access Control (MAC) address Packet length Precedence Protocol VLAN Link Efficiency Mechanisms Congestion Management andAvoidance Immediate Actions Classify Traffic Post-Queuing Queuing and Scheduling Pre-Queuing Classification Policy Actions Keyword: Policy-Map Match Conditions Keyword: Class-Map 15. Abordagem tecnolgica Arquiteturas da QoS -DiffServTipo de Servios (ToS) DiffServ Codepoint FieldIPv4 ToS Byte 16. Abordagem tecnolgica Arquiteturas da QoS DiffServ Tabela de cdigos AF

  • Fatores de entrega de um pacote por PHB AF:
  • Classe AF ao qual pertence: Quanto maior o valor, maior a probabilidade
  • Trfego agregado atual da referida classe.
  • Valor da precedncia de descarte do pacote: quanto menor a precedncia, maior a probabilidade

(AF43) 100110 (AF33) 011110 (AF23) 010110 (AF13) 001110 High Drop Precedence (AF42) 100100 (AF32) 011100 (AF22) 010100 (AF12) 001100 Medium Drop Precedence (AF41) 100010 (AF31) 011010 (AF21) 010010 (AF11) 001010 Low Drop Precedence Class #4 Class #3 Class #2 Class #1 DROP Precedence 17. Abordagem tecnolgica Arquiteturas da QoS -DiffServRelao dos valores de CoS, IPP e DSCP Rede 56-63 7 7 Internet 48-55 6 6 Crtico 40-47 5 5 Flash-Ovirride 32-39 4 4 Flash 24-31 3 3 Imediato 16-23 2 2 Prioridade 8-15 1 1 Roteamento (Melhor Esforo) 0-7 0 0 Nome DSCP Precedncia de IP CoS 18. Abordagem tecnolgica Arquiteturas da QoS-DiffServArquitetura 19. Abordagem tecnolgica Arquiteturas da QoS comDiffServ Classificao Do Trfego Baixa Latncia (Voz RTP/IAX) Latncia e entrega Garantidas (SIP/H323 e Vdeo) Entrega garantida Melhor esforo CRM/E-commerce/ERP MSN/Gnutella/Outros Web/E-mail Telefonia IP 20. Abordagem tecnolgica

  • Arquiteturas da QoS
    • Caractersticas da QoS
      • Weightedfair queuing (WFQ, enfileiramento justo ponderado)
        • Enfileiramento baseado em fluxos que executa duas tarefas simultneas: Programar o trfego interativo para a frente da fila a fim de reduzir o tempo de resposta e dividir a largura de banda restante entre os fluxos de alta largura de banda
        • Padro em roteadores Cisco com seriais de at 2 Mbps
      • Class-based weighted fair queuing (CBWFQ, enfileiramento justo ponderado baseado em filas
        • Permite a configurao de classes de trfego, classificando os fluxos em filas e atribuindo prioridades diferentes.
        • Muito utilizado em redes com VoIP.

21. Abordagem tecnolgica

  • Arquiteturas da QoS - Caractersticas da
    • Enfileiramento de prioridades
      • um algoritmo semelhante ao WFQ, porm os nveis mais prioritrios tm total preferncia em relao aos de menor prioridade. Contudo este tipo de algoritmo deve ser muito bem administrado, pois pode ocorrer de quando houver um grande fluxo de pacotes de alta prioridade, fazer com que os pacotes de baixa prioridade sofram um atraso muito grande ou at mesmo sejam descartados.
    • Enfileiramento personalizado
      • Aloca partes da banda para determinados fluxos e a outra parte dividida para os demais fluxos. A cada ciclo so liberados os pacotes conforme a proporo alocada inicialmente para cada fluxo.

22. Abordagem tecnolgica

  • Arquiteturas da QoS Caractersticas
    • Low-latency queuing (LLQ, enfileiramento de baixa latncia)
      • um enfileiramento justo ponderado baseado em classes com uma fila de prioridade restrita. Uma fila de prioridade restrita onde o hardware usado para enviar pacotes que precisam ser enviados com a menor latncia possvel.
      • Altamente recomendado para redes que trafegam voz e vdeo, onde qualquer latncia ou atraso (jitter) causa problemas.

23. Abordagem tecnolgica

  • Arquiteturas da QoS Caractersticas
    • Montagem de trfego
      • A montagem de trfego, monitora o trfego e, quando ele atinge um limite, em vez de descartar pacotes, os mantm at o ponto onde a largura de banda diminui at que comeam a ser transmitidos.
      • Exige muita memria, uma vez que faz alta utilizao de buffer e quando transborda, os pacotes so descartados.
      • No recomendado para VoIP, uma vez que os pacotes de voz devem entregues em ordem e com baixa latncia.

24. Abordagem tecnolgica

  • MPLS (Multiprotocol Label Switching)
      • Protocolo que atua entre as camadas 2 e 3, onde ele faz o chaveamento dos pacotes atravs de rtulos.
      • Tecnologia conhecida como comutao por rtulos.
      • MPLS no uma nova tecnologia de QoS, ou seja, o MPLS utiliza as tcnicas de DiffServ para fazer QoS.
      • Transporte Ponto-a-Ponto atravs de VPN

25. Abordagem tecnolgica MPLSLER Label Edge Router LER Label Edge Router LSR Label Switch Router LSP Label Switch Path 26. Abordagem tecnolgica MPLSLabel Switching Forward Tables (Tabelas de encaminhamento dos comutadores de rtulo) Forwarding Equivalency Class (FEC) 27. Abordagem tecnolgica

  • MPLS
    • Uma FEC consiste numa classe de equivalncia, ou seja, um conjunto de parmetros, que iro determinar um caminho para os pacotes. Os pacotes associados a uma mesma FEC sero encaminhados pelo mesmo caminho.
    • A FEC representada por um rtulo e cada LSP associada a uma FEC. Ao receber um pacote, o roteador de entrada da rede MPLS verifica qual FEC ele pertence e o encaminha atravs da LSP correspondente. A associao do pacote a uma FEC acontece apenas uma vez, quando o pacote entra na rede MPLS. Isto proporciona grande flexibilidade e escabilidade a este tipo de rede.
    • FEC pode ser determinada por um ou mais parmetros, especificados pelo gerente da rede. Alguns desses parmetros so:
      • Endereo IP da fonte ou destino ou endereo IP da rede
      • Nmero da porta da fonte ou destino
      • ID do protocolo IP
      • QoS

28. Abordagem tecnolgica

  • No que a QoS pode me ajudar?

29. Abordagem tecnolgica

  • Partida
  • A QoS garante a largura de banda
  • A QoS utilizada para resolver problemas de congestionamento na Rede
  • A QoS utilizada para garantir que aplicaes de tempo real no percam a qualidade
  • Contrapartida
  • A QoS no limita largura de banda
  • A QoS no resolve problemas de link saturado
  • A QoS no evita que os pacotes sejam eliminados
  • A QoS no divide o link em links lgicos menores

30. Abordagem tecnolgica

  • Principais fabricantes
    • Cisco (Router, Switch, IPS e Firewall)
    • Nortel (Router e Switch)
    • Juniper (Router e Firewall)
    • Enterasys (Switch)
    • 3Com (Switch, IPS e Firewall)
    • Huawei (Router e Switch)
    • Alcatel (Switch)

31. Abordagem tecnolgica

  • QoS em Software Livre
    • Linux
      • TC, Iptables e IProute2
        • PFIFO, PRIOQ, CBQ e HTB
    • FreeBSD e OpenBSD
      • PF
        • CBQ, HFSC

32. Antes do Projeto

  • O Cliente no Div
    • Onde estou
    • Onde quero chegar
    • Como chegar l
  • Conquiste a equipe tcnica do cliente
    • So formadores de opinio
    • Ajudam na deciso final
    • Evita a concorrncia

33. Antes do Projeto

  • Onde estou: Levantamento do Ambiente
    • Fornecedores de Telecomunicaes
    • Ambiente de telefonia atual
    • Rede Ethernet
      • Cabeamento
      • HUB
      • SWITCH
      • Firewall
    • Rede WAN
      • Meio de comunicao
        • Banda larga, MPLS, Frame-relay, PPP e ATM
      • Equipamentos de comunicao
        • Dispositivos de Rede (Routers, Switch)

34. Antes do Projeto

  • Onde quero chegar
    • Ambiente integrado
      • Voz, Vdeo, Colaborao, Dados
    • Modernizao
      • Tecnologia de ponta
      • Melhor relao Custo x Benefcio
    • Vaidade
      • Eu tenho, voc no tem!!!!

35. Antes do Projeto

  • Como chegar l
    • Anlise mercadolgica das solues de Convergncia
      • No definir tecnologia legada
      • Suporte ps-venda
    • Relacionamento com fornecedores
      • Gerar demanda por obter melhores preos
      • Quanto menor o valor do desencaixe mais chances de fechar o projeto
    • Segurana deve ser um requisito mnimo
    • Plano de continuidade de negcios (PCN)
    • O cliente precisa ser atendido com responsabilidade!

36. Definio do ambiente de inspeo

  • O ambiente de inspeo informar:
    • Qual o perfil do trfego dos usurios
    • Quais so os gargalos da rede
    • Quais os protocolos mais utilizados
  • Ferramentas
    • Servidor Linux (Centos 5)
      • Flow-tools Switch de aplicaes que captura e processa os pacotes Netflow
      • Fprobe Captura pacotes na interface do servido linux e envia para o Servidor de Netflow
      • Cacti com o plugin Flow Viewer Ferramente de anlise grfica dos pacotes Flow
      • Flowscan L as informaes geradas pelo Flow-tools (flow-capture) e gera informaes em base de dados RRD para anlise grfica
      • CUGrapher CGI em Perl que l as informaes dos arquivos RRD gerados pelo Flowscan

37. Definio do ambiente de inspeo

  • Inspeo utilizando Servidores Linux
    • fprobe-t192.168.2.200:5000-ieth0
  • Inspeo utilizando Switch (Port mirroring)
    • Cisco 3750
      • monitor session 1 destination interface gigabitEthernet 1/0/28
      • monitor session 1 source interface GigabitEthernet 1/0/1
    • 3COM 5500
      • [SW5500-Ethernet3/0/8]monitor-port
      • [SW5500-Ethernet3/0/1]mirroring-port both
    • Dell 6248
      • monitor session 1 destination interface 1/g10
      • monitor session 1 source interface 1/g1

38. Definio do ambiente de inspeo

  • Inspeo utilizando Roteadores Cisco
    • Cisco Netflow
      • ip flow-export version 5 origin-as
      • ip flow-export destination 192.168.2.200 5000
      • ip flow-export source Loopback0
      • interface Loopback0
      • ip address 10.1.1.1 255.255.255.255
      • interface FastEthernet0/1/0
      • ip address 192.168.2.10 255.255.255.0
      • no ip directed-broadcast
      • ip route-cache flow
      • ip route-cache distributed

39. Definio do ambiente de inspeo Switch Firewall Router Servidor De Inspeo Interfaces de Inspeo Asterisk Netflow Fprobe Port Mirroring Flow-tools Fprobe Flowscan CUGraph CGI Cacti + Flow Viewer 40. Definio do ambiente de inspeo Cacti com o plugin Flow Viewer 41. Definio do ambiente de inspeo CUGrapher 42. Definio do ambiente de inspeo

  • O resultado, segundo Charles Darwin!!!

O Usurio O Cliente 43. Elaborao do Projeto

  • Estudo de Casos por Cenrios
    • Cliente 01 Empresa de Tranportes
      • 1 Matriz (Rio de Janeiro)
      • 2 Unidades (So Paulo e Curitiba)
      • Ambiente encontrado
        • Utilizao de frame-relay com CIR de 256 Kbps na Matriz, CIR de 128 Kbps nas Filiais. Com a crescente demanda de interconexo, o frame-relay no suporta mais o ambiente do cliente
        • Acesso a internet por banda larga nas unidades e dedicado (2 Mbps) na Matriz
        • Rede est satura e cliente precisa de expanso
          • No possui firewall
          • Ligao pela Operadora VoIP, utilizando a Internet no funciona direito
        • PABX, tanto da Matriz quanto das Unidades, no suportam crescimento e o Depto. Financeiro est preocupado com a valor mensal da Conta Telefnica
      • Necessidades
        • Interligar as unidades obter recursos de Telefonia IP
        • Centralizar sada de acesso a internet na matriz
        • Prover vdeo conferncia
        • Reduzir custos de LDN
        • Tarifao de chamadas por usurio e centros de custo
      • Cliente tem verba disponvel para o projeto

44. Elaborao do Projeto

  • Estudo de Casos por Cenrios
    • Cliente 01
      • Soluo
        • Rede WAN MPLS
        • Rede LAN Switch Multicamada
        • Firewall Linux com QoS
        • IPBX Asterisk SIP, IAX2 Trunk, ISDN
        • Telefones IP, ATA e Softphone

45. Elaborao do Projeto Switch Firewall Router Asterisk Router Router Router Switch Asterisk Asterisk Switch MPLS Internet

  • Estudo de Casos por Cenrios
    • Cliente 01 Topologia

Curitiba So Paulo Rio de Janeiro 46. Elaborao do Projeto

  • Estudo de Casos por Cenrios
  • Cliente 01 Design Tcnico
  • Vlan de Voz, Vlan Hibrida e Vlan de Dados
  • Roteamento de pacotes entre Vlan Hibrida para softphone na Vlan de Voz
  • QoS
    • RTP, IAX2: IP Precedence 5 (EF)
    • SIP, H263, H264: (AF41)
    • ERP, CRM: (AF11)
    • Outros: Best Effort
  • VPN MPLS DiffServ
  • IAX2 Trunk entre Filiais e Matriz
    • Codec G729
  • SIP Clients (ATA, Telefone IP e Softphone)
    • G711u (Ulaw)
  • SIP Trunk para operadora de Telefonia IP
  • Firewall com Proxy Squid e OpenVPN
    • NAT 1:1 para o Asterisk conectado ao Provedor VoIP com SIP
    • Regras de QoS utilizando PRIO
  • Sada para PSTN utilizando o IPBX Local com rota de menor custo entre as localidades

47. Elaborao do Projeto

  • Estudo de Casos por Cenrios
    • Cliente 02 Empresa do ramo de sade
      • 1 Matriz e 4 Unidades (So Paulo)
      • Ambiente encontrado
        • Utilizao de frame-relay com CIR de 2 Mbps na Matriz, CIR de 512 Kbps nas Filiais. Com a crescente demanda de interconexo, o frame-relay no suporta mais o ambiente do cliente
        • Acesso a internet dedicado (2 Mbps) na Matriz
        • Rede est satura e cliente precisa de expanso
          • Possui firewall
        • PABX, tanto da Matriz quanto das Unidades, no suportam crescimento e o Depto. Financeiro est preocupado com a valor mensal da Conta Telefnica
      • Necessidades
        • Interligar as unidades obter recursos de Telefonia IP
        • Prover vdeo conferncia
        • Reduzir custos de LDN
        • Tarifao de chamadas por usurio e centros de custo
      • Cliente tem verba disponvel para o projeto

48. Elaborao do Projeto

  • Estudo de Casos por Cenrios
    • Cliente 02
      • Soluo
        • Rede MAN Metro Ethernet
        • Rede LAN Switch Multicamada
        • Firewall Linux com QoS
        • IPBX Asterisk SIP, IAX2 Trunk, ISDN
        • Telefones IP, ATA e Softphone

49. Elaborao do Projeto Switch

  • Estudo de Casos por Cenrios
    • Cliente 02 Topologia

Asterisk Firewall Router Internet Switch Switch Switch Metro Ethernet Switch Asterisk Asterisk Asterisk Asterisk Unidades Matriz 50. Elaborao do Projeto

  • Estudo de Casos por Cenrios
  • Cliente 02 Design Tcnico
  • Vlan de Voz, Vlan Hibrida e Vlan de Dados
  • Roteamento de pacotes entre Vlan de hibrida para softphone na vlan de Voz
  • QoS
    • RTP, IAX2: IP Precedence 5 (EF)
    • SIP, H263, H264: (AF41)
    • ERP, CRM: (AF11)
    • Outros: Best Effort
  • Metro Ethernet com Encapsulamento de Vlan (802.1q)
  • Utilizao do Dundi para Unificao de Ramais
  • IAX2 Trunk entre Filiais e Matriz
    • Codec G729
  • SIP Clients (ATA, Telefone IP e Softphone)
    • G711u (Ulaw)
  • SIP Trunk para operadora de Telefonia IP
  • Firewall com Proxy Squid e OpenVPN
    • NAT 1:1 para o Asterisk conectado ao Provedor VoIP com SIP
    • Regras de QoS utilizando PRIO
  • Sada para PSTN utilizando o IPBX da Matriz

51. Implementao do Projeto

  • Configurando QoS no Asterisk
    • sip.conf
      • tos_sip=af41; Sets TOS for SIP packets.
      • tos_audio=ef; Sets TOS for RTP audio packets.
      • tos_video=af41; Sets TOS for RTP video packets.
    • iax.conf
      • tos=ef

52. Implementao do Projeto

  • Configurando QoS no Cisco Router
    • Cisco Router (CLASSES)
      • class-map Silver
      • match ip dscp cs3
      • class-map Gold
      • match ip dscp af41
      • class-map Permium
      • match ip dscp ef
      • policy-map WAN
      • class Premium
      • priority 760
      • class Gold
      • bandwidth percent 20
      • class Silver
      • bandwidth percent 40
      • class class-default
      • fair-queue
  • Cisco Router (Interface)
    • interface Serial0/0
    • bandwidth 2048
    • ip address 200.0.1.1 255.255.255.252
    • encapsulation ppp
    • fair-queue
    • service-policy output WAN

53. Implementao do Projeto

  • Configurando QoS no Switch Cisco
    • Interface com PC Softphone (Configurando o valor da Class of Service CoS)
      • interface GigabitEthernet1/0/12
      • mls qos cos 5
      • switch port mode access
      • switch access vlan 10

54. Implementao do Projeto

  • Configurando QoS no Switch Cisco
    • Interface com iPBX Asterisk
    • interface GigabitEthernet1/0/12
      • auto qos voip trust
      • switch port mode access
      • switch access vlan 10

55. Implementao do Projeto

  • Configurando QoS no Switch Dell 6248
    • console# config
    • cos-queue strict 5
    • class-map match-all class_voip
    • match protocol udp
    • exit
    • class-map match-all class_ef
    • match ip dscp ef
    • exit
    • policy-map pol_voip in
    • class class_ef
    • assign-queue 5
    • exit
    • class class_voip
    • mark ip-dscp ef
    • assign-queue 5
    • exit
    • exit
    • interface ethernet 1/g2
    • service-policy in pol_voip
    • exit

56. Implementao do Projeto

  • Configurando QoS no Firewall Linux
  • tc qdisc add dev eth0 root handle 1: prio priomap 2 2 2 2 2 2 2 2 1 1 1 1 1 1 1 0
    • tc qdisc add dev eth0 parent 1:1 handle 10: sfq
    • tc qdisc add dev eth0 parent 1:2 handle 20: sfq
    • tc qdisc add dev eth0 parent 1:3 handle 30: sfq
    • tc filter add dev eth0 protocol ip parent 1: prio 1 u32 match ip tos 0xb8 0xff flowid 1:1
    • tc filter add dev eth0 protocol ip parent 1: prio 1 u32 match ip tos 0x68 0xff flowid 1:2

57. Documentao da Rede

  • A documentao da rede precisa:
    • Montar o diagrama fsico e lgico do ambiente
    • Encontrar e especificar os pontos de falhas com o objetivo de mitigar o eventos com pr-atividade: Troubleshooting
    • Especificar o SLA dos fornecedores para uma resposta rpida a problemas de paradas e instabilidade
    • Especificar as configuraes dos equipamentos de interconexo
    • Valores de latncia e atraso dos pontos de interconexo
    • Delinear o tempo de convergncia dos equipamentos d alta disponibilidade
    • Especificar os ndices de crescimento para expanso da rede

58. Elaborando um plano de Gerenciamento

  • Cacti ( www.cacti.net )
    • Gerencia de Falhas
      • Plugin Monitor
      • Plugin Thresholds
    • Gerencia de Performance
      • Grficos RRDTools
      • Diagrama de Rede com plugin Network Weathermap
      • Plugin para Asterisk (http://forums.cacti.net/viewtopic.php?p=111317)
  • Flow
    • Flow-tools
    • Fprobe
    • Flowviwer
    • CUGrapf

59. Elaborando um plano de Gerenciamento 60. Elaborando um plano de Gerenciamento 61. Elaborando um plano de Gerenciamento 62. Elaborando um plano de Gerenciamento 63. Empresa

  • O InfoLink Teleinformtica uma empresa 100% Brasileira atuando no mercado de comunicaes de dados desde 1995.
  • Aproveitando toda nossa experincia em comunicao de dados corporativa, que exige extrema confiabilidade, lanamos nosso provedor Internet InfoLink tambm para o mercado de pessoas fsicas em Fevereiro de 1996.
  • Nestes anos de operao com grande sucesso, aumentamos nossa gama de servios e hoje atuamos tambm no segmento de redes locais, segurana e hospedagem de Websites, alm da provedoria de Internet e da comunicao corporativa.
  • Rodrigo Ricardo Passos, Av. das Amricas 500, Bloco 21 Sala 261, (21) 2104-1942, http://www.infolink.com.br